OpenBSD.
I have OpenBSD running on a Raspberry Pi 3B+ as a home server hosting this wiki. I really enjoy the secure-by-default stance, quality documentation, and all the nice things they've added to the OS to help applications be more secure. It's quite well-suited for server applications.
I used to run OpenBSD on my Lenovo ThinkPad X250 as a daily driver from 6.7 through 7.1, but something broke in the X windows system during the upgrade to 7.1 and I couldn't be bothered to fix it, so that ThinkPad runs Manjaro Linux these days. The Spectre/Meltdown mitigations and disabled Bluetooth are fantastic from a security standpoint, but don't lend themselves well to convenient computing like running a Linux distro does.
notes.
- update system:
syspatch; pkg_add -u
- search for a package:
pkg_info -Q ripgrep
- install a package:
pkg_add ripgrep
- search manpages for "unveil" with
apropos:
apropos unveil
- introduction to the C libraries.
- mount sd card in
OpenBSD:
mount.exfat /dev/sd1i /mnt/sd
- mount thumbdrive in OpenBSD:
mount /dev/sd1i /mnt/thumbdrive
- burn image to thumbdrive sd1 (verify with
dmesg
) in OpenBSD:dd if=some.img of=/dev/rsd1c
- execute a command over ssh as if it were a local shell:
ksh -l -c your_command
- brother printer driver using cups on localhost and brlaser: http://localhost:631/printers/
- brother printer queue is at: http://printer_ip_address:631/ipp
- ksh has a user process data limit that can keep qemu from spawning VMs. You
can view ksh's limits with
ulimit -a
and adjust the data limit to 4 GB withulimit -d 4194304
. - specify compiler for GNU configure scripts:
CXX=clang++ ./configure
- Free Pascal Compiler installation.
- Web log analysis using GoAccess.
- Getting a bunch of security(8) emails
about mismatched /dev permissions?
cd /dev; doas ./MAKEDEV
-
schedule tasks with at:
at 5am Oct 20 at "time am/pm" "month" "day" atq lists the user's pending jobs atrm deletes jobs, identified by their job number Ctrl-d once done editing use Ctrl-d to close the "at" entry shell
-
specify /usr/local libraries for compiling with configure scripts and gcc:
export CPATH=/usr/local/include export LIBRARY_PATH=/usr/local/lib export LD_LIBRARY_PATH=/usr/local/lib
-
Get accents to show up correctly in Vim by adding this to ~/.profile:
LC_ALL=en_US.UTF-8 export LC_ALL
-
configure wifi with hostname.if:
join home-net wpakey passwordhere join work-net wpakey passwordhere join cafe-wifi dhcp